-强连通分量-图论- [洛谷 P2860][USACO06JAN]冗余路径Redundant Paths

题目描述

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

为了从F(1≤F≤5000)个草场中的一个走到另一个,贝茜和她的同伴们有时不得不路过一些她们讨厌的可怕的树.奶牛们已经厌倦了被迫走某一条路,所以她们想建一些新路,使每一对草场之间都会至少有两条相互分离的路径,这样她们就有多一些选择.

每对草场之间已经有至少一条路径.给出所有R(F-1≤R≤10000)条双向路的描述,每条路连接了两个不同的草场,请计算最少的新建道路的数量, 路径由若干道路首尾相连而成.两条路径相互分离,是指两条路径没有一条重合的道路.但是,两条分离的路径上可以有一些相同的草场. 对于同一对草场之间,可能已经有两条不同的道路,你也可以在它们之间再建一条道路,作为另一条不同的道路.

输入格式

Line 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

输出格式

Line 1: A single integer that is the number of new paths that must be built.

输入样例

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

输出样例

2

说明

Explanation of the sample:

One visualization of the paths is:

1 2 3

+—-+—-+

| |
| |

6 +—-+—-+ 4

/ 5 / / 7 +Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions.

1 2 3

+—-+—-+
:

6 +—-+—-+ 4

/ 5 : / :

/ :

7 + - - - - Check some of the routes:

1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2

1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4

3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7

Every pair of fields is, in fact, connected by two routes.

It’s possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

Solution

将这道题目描述转换成人话:求出最少的加边数量使这个图无割边。

然后就很好理解了,我们可以先将这个图缩点,因为在无向图的环上是没有割边的(总感觉哪里说的不对),然后这个图就变成了一棵树。最后求一下叶子结点的个数+1再除以2就行了。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define MAXN 1001000
int min(int a, int b) {
if (a < b) return a;
else return b;
}
struct Edge {
int f, v, nx;
}e[MAXN];
int head[MAXN], ecnt, dfn[MAXN], low[MAXN], n, m, x, y, tim, st[MAXN], top, g[MAXN];
int num, br, in[MAXN];
bool mp[5005][5005];
void add(int f, int t) {
e[++ecnt] = (Edge) {f, t, head[f]};
head[f] = ecnt;
}
void tarjan(int u, int fa) {
dfn[u] = low[u] = ++tim;
st[++top] = u;
for (int i = head[u]; i; i = e[i].nx) {
int v = e[i].v;
if (fa == v) continue;
if (!dfn[v]) {
tarjan(v, u);
low[u] = min(low[u], low[v]);
}
else low[u] = min(dfn[v], low[u]);
}
if (low[u] == dfn[u]) {
int v;
num++;
do {
v = st[top--];
in[v] = num;
} while (u != v);
}
}
int main() {
scanf("%d%d", &n, &m);
for (int i = 1; i <= m; i++) {
scanf("%d%d", &x, &y);
if (mp[x][y] || mp[y][x]) {
continue;
}
add(x, y);
add(y, x);
mp[x][y] = mp[y][x] = 1;
}
for (int i = 1; i <= n; i++) {
if (!dfn[i]) tarjan(i, -1);
}
for (int i = 1; i <= ecnt; i += 2) {
int f = e[i].f, v = e[i].v;
if (in[f] != in[v]) {
g[in[f]]++;
g[in[v]]++;
}
}
for (int i = 1; i <= num; i++) {
if (g[i] == 1) br++;
}
printf("%d", (br + 1) >> 1);
return 0;
}
文章作者: RiverFun
文章链接: https://stevebraveman.github.io/blog/2018/12/12/51/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 RiverFun

评论