-网络流-最大流- [洛谷 P2891][USACO07OPEN]吃饭Dining

题目描述

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

有F种食物和D种饮料,每种食物或饮料只能供一头牛享用,且每头牛只享用一种食物和一种饮料。现在有n头牛,每头牛都有自己喜欢的食物种类列表和饮料种类列表,问最多能使几头牛同时享用到自己喜欢的食物和饮料。(1 <= f <= 100, 1 <= d <= 100, 1 <= n <= 100)

输入格式

Line 1: Three space-separated integers: N, F, and D

Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

输出格式

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

输入样例

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

输出样例

3

说明

One way to satisfy three cows is:

Cow 1: no meal

Cow 2: Food #2, Drink #2

Cow 3: Food #1, Drink #1

Cow 4: Food #3, Drink #3

The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Solution

这道题很多人把它说成是三分图最大匹配,但是这道题把它拆成两个二分图然后再进行匹配很不好做,于是就可以用网络流的最大流解决,把牛进行拆点,然后再根据题意连边就行了。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
#define MAXN 1000002
#define INF 2000000000
int min(int a, int b) {
if (a < b) return a;
else return b;
}
struct Edge {
int v, nx, w;
} e[MAXN];
std::queue <int> q;
int n, m, head[MAXN], ecnt = 1, x, y, z, r, k, dep[MAXN], cur[MAXN], cnt = 1, totp = 0, tot, xi, yi, c;
void add(int f, int t, int w) {
e[++ecnt] = (Edge) {t, head[f], w};
head[f] = ecnt;
e[++ecnt] = (Edge) {f, head[t], 0};
head[t] = ecnt;
}
bool bfs(int s, int t) {
memset(dep, 0x7f, sizeof(dep));
while (!q.empty()) q.pop();
for (int i = 1; i <= n + m + c + n + 2; i++) {
cur[i] = head[i];
}
dep[s] = 0;
q.push(s);
while (!q.empty()) {
int v = q.front();
q.pop();
for (int i = head[v]; i; i = e[i].nx) {
int to = e[i].v;
if (dep[to] > INF && e[i].w) {
dep[to] = dep[v] + 1;
q.push(to);
}
}
}
if (dep[t] < INF) return 1;
else return 0;
}
int dfs(int u, int t, int l) {
if (!l || u == t) return l;
int fl = 0, f;
for (int i = cur[u]; i; i = e[i].nx) {
cur[u] = i;
int to = e[i].v;
if (dep[to] == dep[u] + 1 && (f = dfs(to, t, min(l, e[i].w)))) {
fl += f;
l -= f;
e[i ^ 1].w += f;
e[i].w -= f;
if (!l) break;
}
}
return fl;
}
int Dinic(int s, int t) {
int maxf = 0;
while (bfs(s, t)) {
maxf += dfs(s, t , INF);
}
return maxf;
}
int a[MAXN], b[MAXN];
int main() {
scanf("%d%d%d", &n, &m, &c);
r = 2 * n + m + c + 1;
k = 2 * n + m + c + 2;
for (int i = 1; i <= m; i++) {
add(r, i, 1);
}
for (int i = 1; i <= c; i++) {
add(m + i, k, 1);
}
for (int i = 1; i <= n; i++) {
add(i + c + m, i + c + m + n, 1);
}
for (int i = 1; i <= n; i++) {
scanf("%d%d", &x, &y);
for (int j = 1; j <= x; j++) {
scanf("%d", &xi);
add(xi, i + c + m, 1);
}
for (int j = 1; j <= y; j++) {
scanf("%d", &yi);
add(i + c + m + n, yi + m, 1);
}
}
tot = Dinic(r, k);
printf("%d\n", tot);
return 0;
}
文章作者: RiverFun
文章链接: https://stevebraveman.github.io/blog/2019/01/07/56/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 RiverFun

评论